24/05/2018, 21:13

Cấu hình router-router dial-up

Xem mô hình sau: Ví dụ kết nối router-to-router. Đối với mô hình router-router dial-up thì một router phải đóng vai trò answering và một router đóng vai trò dialing. Để cấu hình router-router dial-up, phải cấu hình ...

Xem mô hình sau:

Ví dụ kết nối router-to-router.

Đối với mô hình router-router dial-up thì một router phải đóng vai trò answering và một router đóng vai trò dialing.

Để cấu hình router-router dial-up, phải cấu hình cho cả router answering và router dialing trong đó router dialing phải được cấu hình cho việc quay số ra bao gồm chat-script, dialer map, ip route… Lệnh ip route dùng để thiết lập static route (đã trình bày ở phần config leased line):

ip route network[mask]{address | interface}[distance][permanent]
  • Cấu hình answering access server (Snoopy):
!
version 12.0
!
hostname Snoopy
!
enable password test
!
aaa authentication ppp default local
!
username Woodstock password 7 kd345096ix09ghu934c=e
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0 no ip address shutdown
!
interface Serial1 no ip address shutdown
!
interface Async1
ip unnumbered Ethernet0
encapsulation ppp
peer default ip address 172.16.20.1
async dynamic routing async mode dedicated
dialer idle-timeout 300
dialer map ip 172.16.20.1 name Woodstock broadcast
ppp authentication chap
dialer-group 1
!
router rip
network 172.16.0.0
!
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 list 100
!
ip route 0.0.0.0 0.0.0.0 172.16.20.1
ip route 172.16.20.1 255.255.255.255 async1
!
line con 0
line aux 0
modem dialin speed 115200
flowcontrol hardware line vty 0 4
password cisco
!
end
  • Cấu hình cho dialing access server (Woodstock):
!
version 12.0
!
hostname Woodstock
!
enable password test
!
username Snoopy password peanuts
chat-script dialnum "" "atdtT" TIMEOUT 60 CONNECT c
chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m0&k0" "OK"
!
interface Ethernet0
ip address 172.16.20.1 255.255.255.0
!
interface Serial0
no ip address
!
interface Serial1
no ip address
!
interface Async1
ip unnumbered Ethernet0
encapsulation ppp
async default ip address 172.16.10.1
async dynamic routing async mode dedicated
dialer in-band
dialer idle-timeout 300
dialer map ip 172.16.10.1 name Snoopy modem-script dialnum broadcast 14085554321
dialer-group 1
ppp authentication chap pulse-time 3
!
 


router rip
network 172.16.0.0
!
ip route 0.0.0.0 0.0.0.0 172.16.10.1
ip route 172.16.10.1 255.255.255.255 async 1
!
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 list 100
!
line con 0
line aux 0 modem InOut speed 115200
script reset rstusr flowcontrol hardware
!
line vty 0 4 password test login
!
end

Ta có thể không sử dụng lệnh ip unnumbered mà gán địa chỉ trực tiếp cho cổng async như sau:

  • Cấu hình answering access server (Snoopy):
...
interface Async1
ip address 172.16.30.1 255.255.255.0
encapsulation ppp
peer default ip address 172.16.30.2 ( hay async dynamic address đều được)
async dynamic routing async mode dedicated
dialer idle-timeout 300
dialer map ip 172.16.30.2 name Woodstock broadcast ppp authentication chap
dialer-group 1
...
  • Cấu hình cho dialing access server (Woodstock):
...
interface Async1
ip address 172.16.30.2 255.255.255.0
encapsulation ppp
async default ip address 172.16.30.1 ( hay async dynamic address đều được)
async dynamic routing async mode dedicated
dialer in-band
dialer idle-timeout 300
dialer map ip 172.16.30.1 name Snoopy modem-script dialnum broadcast 14085554321
dialer-group 1
ppp authentication chap pulse-time 3
!
router rip
network 172.16.0.0
!
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.1 255.255.255.255 async 1
!
...
0